O que você está procurando?

Aperte Enter para buscar ou ESC para fechar

Corrigindo o erro ‘Allowed memory size Exhausted’ no WordPress

2 min de leitura

Um pequenho hackzinho que pode ajudar aqueles que passaram pelo mesmo problema que passamos por aqui. Ao atualizar nosso site para o WordPress 2.8 (após um lógico backup de tudo), a seção administrativa do site apresentava a seguinte mensagem de erro:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2348617 bytes) in …

Como o próprio erro menciona, o problema aconteceu pois o limite de memória do servidor (32 MB) foi alcançado, faltando assim memória disponível para carregar corretamente os arquivos do sistema. Isso normalmente ocorre quando temos muitos plugins ativos, consumindo a memória do servidor. Tal erro pode vir a acontecer também quando o usuário estiver usando plugins em excesso em sua instalação WordPress.

Mas tudo bem, caso enfrente este problema, siga uma das duas dicas abaixo, uma delas resolverá seu problema!

Dica 1 – Método mais simples:

Adicione a linha abaixo no arquivo /wp-config.php

define(‘WP_MEMORY_LIMIT’, ’64M’);

Dica 2 – Método mais longo:

Adicione a linha abaixo no arquivo /wp-includes/cache.php imediatamente após a abertura da tag <?php :

ini_set(‘memory_limit’,’64M’); // set memory to prevent fatal errors

Depois disso,  crie um arquivo .htaccess com o código abaixo e o insira na pasta wp-includes:

# set memory limit for cache.php php_value memory_limit 64M

Finalmente, crie um arquivo php.ini e o coloque também no diretório wp-includes:

;; set memory limit for cache.php memory_limit = 64M

E pronto.. salve tudo, faça o upload dos arquivos e tente novamente entrar no admin de seu site.

Infelizmente, esta dica não funcionará sempre, dependerá muito das configurações de seu servidor.. mas mesmo assim, vale a pena tentar !

Compartilhar este artigo
Guga Alves

Guga Alves

• WordPress e web

Desbravando o mundo WordPress desde 2007, me especializei também em SEO e entreguei grandes projetos no mercado brasileiro para a partir de 2015 me dedicar ao mercado fora do Brasil. Trabalhei na empresa do criador do WordPress por 4 anos (no WordPress.com, da Automattic) e mais 4 anos em uma das maiores empresas de hospedagens do mundo, a Liquid Web, gerenciando uma equipe de suporte do plugin The Events Calendar. No Brasil, atendi grandes marcas como canal Futura, Corpo Perfeito, Catraca Livre, Hostgator Brasil e Hostnet, também palestrei em diversos eventos e dei aula em cursos livres e pós-graduação (no Rio de Janeiro e em Brasília). Trabalho remoto, viajo bastante, mas minha base é no Rio de Janeiro/RJ.

X GitHub Sobre mim
Leituras Complementares

Continue lendo

Ver todos em Dicas WordPress →

Discussão & Respostas (57)

Espaço moderado para debates técnicos
  1. Itamar
    Itamar
    ↳ Responder

    ao atualizar para o wordpress 2.8, meu temas sumiram, ficou só o modelo padrao o que sera que aconteceu, houve alguma mudança neste item de temas ? abçs

  2. Rafael Hernandez
    Rafael Hernandez
    ↳ Responder

    Santa Cassetada hem…muito bom..no meu WordPress só funciono a 2º opção.

    Parabens pela dica.

    1. Witalo Rebouças
      Witalo Rebouças
      ↳ Responder

      Eae Rafa, blz? Cara acredita que to tendo ess erro com 3.1 que bosta heim, mas vamos ao teste e tentar resolver

  3. Ronaldo
    Ronaldo
    ↳ Responder

    Muito bom cara, resolveu meu problema. Usei a primeira dica. Abraços e sucesso pra você!

  4. Nilton Neto
    Nilton Neto
    ↳ Responder

    Salvou a minha vida.
     
    Obrigado.

  5. Gabriel
    Gabriel
    ↳ Responder

    Muito massa!

    Valeu mesmo, resolveu minha bronca.

    Abraços e sucesso!

  6. DaCoD
    DaCoD
    ↳ Responder

    Dica precisa e direta, resolveu o problema . . .
     
    Tks

  7. Alessandro
    Alessandro
    ↳ Responder

    Cara, você salvou minha vida e muitoas horas de produção… =)
    Obrigado!!!!

  8. jhon
    jhon
    ↳ Responder

    Valeus , muito boa sua dica… Ateh +++

  9. Carlosh
    Carlosh
    ↳ Responder

    amigão vc é o cara! sua dica foi a primeira do google e não por outra razão… ela foi direto ao ponto e resolveu meu problema na hora, muito obrigado!

  10. Rafael Costa
    Rafael Costa
    ↳ Responder

    Infelizmente esse problema não foi resolvido no WordPress 3.1 . Já Pesquisei mais de uma semana e nada. Segue o erro se alguem puder ajudar:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home/moments/public_html/site/wp-includes/class-simplepie.php on line 11777
    Obrigado.

  11. Rafael
    Rafael
    ↳ Responder

    Consegui resolver o problema , porém tive que mudar no WordPress essas configurações:

    As configurações de "memory_limit"  que antes era em wp-includes agora está em default-constants.php .
    Obrigado pela atenção!

    1. Luciano
      Luciano
      ↳ Responder

      Estava tentando com a dica do post, mas como minha versão do wordpress já estava atualizada para a 3.3.1 não consegui.

      As configurações de limite de memória realmente estão em wp-includes / default-constants.php

      Valeu pela dica!!

  12. Kadu Fernandes
    Kadu Fernandes
    ↳ Responder

    Cara, consegui resolver somente com a dica numero 2. Mas funcionou direitinho.
    Parabéns pelo tutorial.
     
    Abraços…

  13. jhoon
    jhoon
    ↳ Responder

    Essa opção funciona …  mais comigo deu certo e logo depois voltou o erro ….    Para isso vc pode pedir para aumentar o arquivo .ini da hospedagem … se isso ainda continuar com esses erros …  vc deleta alguns de seus plugins … pois existem alguns que são muito pessados …. se o erro persistir …  contrate um dedicado … 

  14. Diego Alberto
    Diego Alberto
    ↳ Responder

    EU TE AMO, MEU AMIGO!

  15. Devepment Web
    Devepment Web
    ↳ Responder

    não funcionou no meu caso…

  16. Romero
    Romero
    ↳ Responder

    Prezado Amigo!!
    Obrigado, salvou meu dia!
    Abraço

  17. Ubiratan
    Ubiratan
    ↳ Responder

    Muito obrigado pela dica! Tive esse problema depois de instalar o Plugin Digg Digg. Valeu!!!

  18. Caio
    Caio
    ↳ Responder

    Pode parecer ridiculo, + atualizei meu wordpress para a ultima versão esse final de semana e deu o problema mencionado no post. Vlw Guga pela dica.

  19. Bruno Goyanna
    Bruno Goyanna
    ↳ Responder

    Legal ajudou bastante comigo a primeira dica funcionou em todos os blogs que eu havia migrado de servidor

  20. Germano Bueno
    Germano Bueno
    ↳ Responder

    Caros, tentei a opção 1 e 2, pedi ao meu servidor para aumentar a memória do PHP e eles disseram que a mesma foi aumentada para 512MB e mesmo assim não funcionou… que recomendação me dão?

    essa é a mensagem de erro: Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 122880 bytes) in /home/germano/public_html/wp-admin/includes/dashboard.php on line 324

  21. Magbis
    Magbis
    ↳ Responder

    Muito legal a dica, funcionou com a segunda opção, o site voltou a abrir, mas o ambiente de administração [wp-admin] não abre.

    Alguém pode me ajudar?

  22. Wilder
    Wilder
    ↳ Responder

    FUNCIONOU! A primeira opção. =)
    VLW!!!!

  23. Mauricio
    Mauricio
    ↳ Responder

    Guga, para mim nenhuma das 2 opções funfaram. O erro que dá é o seguinte:

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 122880 bytes) in /home/corescom/public_html/blog/wp-admin/includes/dashboard.php on line 103

    Tem alguma idéia de como possa resolver isso?
    Abs!

    Mauricio

  24. Marcio Gomes
    Marcio Gomes
    ↳ Responder

    eu consegui resolver este problema, fiz o seguinte: wp-includes/default-constants.php

    neste arquivo deixei desse jeito:

    global $blog_id;

    // set memory limits
    if ( !defined(‘WP_MEMORY_LIMIT’) ) {
    if( is_multisite() ) {
    define(‘WP_MEMORY_LIMIT’, ‘256M’);
    } else {
    define(‘WP_MEMORY_LIMIT’, ‘256M’);
    }
    }

    if ( ! defined( ‘WP_MAX_MEMORY_LIMIT’ ) ) {
    define( ‘WP_MAX_MEMORY_LIMIT’, ‘256M’ );
    }

    E o problema foi resolvido…

  25. José Ferreira Neto
    José Ferreira Neto
    ↳ Responder

    Salvou meu dia de serviço…. obrigaduuuuu

  26. Bruno
    Bruno
    ↳ Responder

    Em qualquer linha do codigo?

  27. Luiz
    Luiz
    ↳ Responder

    ;; set memory limit for cache.php memory_limit = 64M

    no luga de 64m eu coloquei 68m e funciono muito bem. muito obrigado pela dica.

  28. Luiz
    Luiz
    ↳ Responder

    no lugar ond é 64m eu coloquei 68m e funciono muito bem

  29. Anilton
    Anilton
    ↳ Responder

    Qual a solução para esse erro, já aumentei o limite da memória do wp-config.php e mesmo assim o erro aparece.

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 19456 bytes) in /home/content/02/11673002/html/wp-includes/functions.php on line 1140

    Fico muito grato se puder me ajudar

  30. Flávio Oliveira
    Flávio Oliveira
    ↳ Responder

    Olá Guga, segui sua receita à risca. Acredito que estatiscamente entrei no grupo dos que não conseguiram fazer funcionar. Faltou sorte … rs. Tenho um backup de tudo o que havia feito antes dessa tentativa de instalação do WooCommerce. Tem idéia de como devo proceder para subir esse backup [inclusive com todas as fotos dos produtos?] Pois da última vez que isso me aconteceu, perdi todas as imagens dos produtos [mais de 250]. Obrigado.

  31. Walter
    Walter
    ↳ Responder

    Muito bom! Fez eu ganhar tempo. Parabéns

    1. Rodrigo Nogueira | rnd4web
      Rodrigo Nogueira | rnd4web
      ↳ Responder

      Oi Leonardo, uso Locaweb e foi certinho. Valeu a dica.

    2. Felipe Marciano
      Felipe Marciano
      ↳ Responder

      Mais um que você salvou!
      Obrigado Leonardo! Genial!

  32. iran
    ↳ Responder

    Valeu, me ajudou bastante na configuração do site de um cliente.

  33. Filipe Nogueira
    Filipe Nogueira
    ↳ Responder

    Muito boa essa dica! Obrigado…
    Inclusive a wiki da locaweb.

  34. Asllan
    Asllan
    ↳ Responder

    Agradeço por ter compartilhado estas informações conosco. Queria deixar registrado, que no meu caso específico não estava funcionando. Alterei de 64M para 128M e funcionou! Então, caso não funcione, vale a pena testar isso também.

  35. Júlio
    Júlio
    ↳ Responder

    Fala ai grande Guga.
    Cara, de inicio eu não consegui mais o erro estava na aspas, eu copiei e colei no notepad++ e ele não as reconheceu, porém após ajustá-las na mão foi só subir o arquivo novamente, eu utilizei a opção 1.
    Parabéns pelo site.

  36. Frederico Silva
    Frederico Silva
    ↳ Responder

    Fiz tudo o que este post diz, mas o problema continuou. Então me lembrei que tinha alterado o meu tipo de hospedagem para Linux, entrei no Painel de Controle do meu servidor de hospedagem e retornei a plataforma para Windows e tudo voltou ao normal. Parece que este problema está relacionado à plataforma Linux.

  37. Claudiano
    Claudiano
    ↳ Responder

    Olá amigos, existe algum tutorial passo a passo para corrigir esse problema. Tenho um site wordpress hospedado pela uolhost e essa semana surgiu esse erro, entrei em contato com o pessoal do uolhost e ele dizem que não podem fazer nada pois o cliente é quem deve administrar o site. Não tenho conhecimento técnico para resolver sozinho, o que sugerem que eu faço?

    Segue o erro: Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 7680 bytes)

    Será que com esse problema devo mudar de hospedagem?

    1. leo
      leo
      ↳ Responder

      Claudiano entre em contato com o seu serviço de hospedagem e diga a eles que vc quer aumentar o memory_limit do php para 64megas

  38. dani
    dani
    ↳ Responder

    Seu lindo… gracias!

  39. Felipe
    ↳ Responder

    Ótimo post, mas aqui resolvi o problema editando o php.ini, a primeira técnica que você mostrou não funcionou no meu caso =(

    O processo de edição do php.ini também é simples, basta clicar em editar e mudar o valor que já deve estar lá de 32mb para 64mb e ser feliz.

  40. Daniel Peixoto
    Daniel Peixoto
    ↳ Responder

    Para mim também funcionou também, mas coloquei 128M.

  41. Carlos Magnun
    Carlos Magnun
    ↳ Responder

    Boa tarde amigos, e se não tiver como relocar memoria , ou seja ja esteja utilizando 256k e nao tenho mais para aumentar, que pode ser feito nesta situação? pedir para meu provedor mudar para um outro plano, ou por ter muita imagem tem haver com essas consequencias e deveria tentar diminuir a qualidade ou pixel dessas fotos. bem agradeço a ajuda antecipadamente. (obs: meu site é em php)

  42. Renato Alves
    Renato Alves
    ↳ Responder

    Valeu demais pela dica amigo. Geralmente esse erro acontece muito quando migro um site da hostgator para a locaweb. Eu não recomendo locaweb. Sempre instável, erros como este são constantes. Tive problemas com vários clientes referente a contas de e-mail através da locaweb. Locaweb é foda. saim fora.

  43. Tiago
    Tiago
    ↳ Responder

    Muito bom!
    Funcionou aqui.
    Valeu mano.

Deixe sua contribuição técnica

Seu e-mail não será publicado. Blocos de código em markdown são aceitos com crases triplas.